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This handbook is destined to the IT administrator, res-
ponsible for the server. It describes how to install and to 
set up the BiblioMaker 7 or Office Maker 7 server software, 
on the server and on the client computers. 

Office Maker and BiblioMaker software systems are ins-
talled and set up in a very similar way. This is why we will 
mention only Office Maker in this handbook.

In the opposite list, click on the topic you are interested in.
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Using Office Maker Server
This chapter describes Office Maker Server’s Administra-
tion window.

In the opposite list, click on the topic you are interested in.

Administration window	 3
Monitor page	 4
Users page	 5
Process page	 6
Maintenance page	 7
Application Server page	 9
SQL Server page	 10
HTTP Server page	 11
Real Time Monitor page	 12
Stop Office Maker Server	 13
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Using Office Maker Server > Administration window 

Administration window
When running, the Office Maker Server software displays a dialog box called Office Maker Server, 
containing several information about the server activity. On the top of the window, several buttons let you 
browse the information pages.

Under Windows, if 
Office Maker Server 
has been registered as 
a service, no window 
is displayed when 
running.
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Using Office Maker Server > Monitor page 

Monitor page

This page displays a graph showing in real time the use of processors, of the network and of the random 
access memory. Click on the pop-up menu under the graph in order to display other information.

Under the graph, several information about the server are displayed : system version, processor model, 
4D Server version, license, use of the hard disk and of the random access memory.

Under Windows, some of the system information displayed on the Monitor page are retrieved via the 
Windows «Performance Analyzer» tools. These tools can only be accessed if the user who opened the 
session where BiblioMaker Server was launched has the necessary authorization. This user must belong 
either to the «Administrators» or to the «Power Users» group (for a user who is not an Administrator). 
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Using Office Maker Server > Users page 

Users page
This page lists the users connected to the server. Please always check this page before stopping 
Office Maker Server. If possible, don’t stop Office Maker Server if there are users connected, because you 
would interrupt a user operation (entering of data, search, etc.). It is better to ask the users to quit Office 
Maker Client before you stop Office Maker Server.

This list may be personalised by moving the columns. A click on a column header sorts the users by the 
value of that column.

On the bottom of the window, three buttons are available :

•	 Send message : sends a message that is immediately displayed on the screen of the selected user(s). 
To select several users simultaneously, use the Shift  or Ctrl (Windows) / Cmd (macOS) keys.

•	 Watch processes : lets you check the current processes for the selected users. Theses processes 
are displayed in the Processes page.

•	 Drop user : disconnects the selected users from the server. Of course, this operation is to be used 
only as final recourse, because if the user is entering data, these data will be lost. This command 
may be used in two cases :

•	 A user has started an operation that is looping indefinitively and cannot stop it.

•	 A user has been disconnected from the server, but the connection is still displayed on the server 
(«phantom connection»). As your Office Maker license is limited to a certain amount of concurrent 
connections, a phantom connection prevents another user from connecting to the server. By 
deleting this connection, you free a connection for another user.
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Using Office Maker Server > Process page 

Process page
This page lists the current processes. It is usually not relevant for the database administrator.
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Using Office Maker Server > Maintenance page 

Maintenance page

This page provides information concerning the current operation of the database. It also provides access 
to basic maintenance functions.

Last verification : displays the last verification’s date. By clicking on Verify records and indexes, you 
start a verification without stopping the server (but the server may be noticeably slowed down during the 
operation). Click on the View report button in order to look at the verification result.

Last compacting : displays the date of the last compacting operation carried out on the database data. 
Click on the Compact data… button to start the compacting operation. As compacting the data stops 
the server, use this command only when no user is connected. Click on the View report in order to look 
at the compacting result.

Uptime : displays the duration of the server operation since the last time it was started. Click on Restart 
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Using Office Maker Server > Maintenance page 

server… if you want to restart BiblioMaker Server immediately. A dialog lets you choose the interruption 
mode : disconnect in x minutes (a message is sent to connected users), wait for all users to disconnect, 
disconnect all users without warning and quit.

Last backup : displays the date and time of the last full database backup, the date and size of the next 
backup. Click on Start backup if you want to backup the database now. You may check and change 
the backup parameters with the Preferences… button. Please note that a backup does not disconnect 
users, but they won’t be able to modifiy the data during the backup. Moreover, new users won’t be able 
to connect to the database during the backup.

Request log : displays the duration of recording log requests. Click on the Start request and debug logs 
button if you want to log the requests (caution, this may noticeably deteriorate server performance) and 
on the View report button in order to look at the log.
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Using Office Maker Server > Application Server page 

Application Server page

This page groups together information about the published database.

Click on the Reject new connections button in order to prevent new users from connecting to the server 
(current connections keep active). The button’s name changes to Accept new connections.

Configuration : this area displays information about the published database : structure file (belonging to 
the program), data file. Please note that by clicking on the file name, you get the file’s full path.

Memory : this area displays the total cache memory (as defined in the database preferences) and the 
used cache memory (dynamic allocation according to the needs).

Maximum connections : maximum number of simultaneous client connects allowed by your license. 
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Using Office Maker Server > SQL Server page 

SQL Server page

This page groups together the information about the integrated SQL server.

Click on the Start SQL Server in order to let users connect to the SQL server. The  button name toggles 
to Stop SQL Server.
Configuration : this area displays information about the SQL server parameters.

Connections : this area displays the current SQL connections.

Maximum connections : maximum number of simultaneous SQL connections depending on the license. 
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Using Office Maker Server > HTTP Server page 

HTTP Server page

This page groups together information about the integrated web server and the SOAP server (used for 
web services) for Office Maker Server.

Status information : displays information about the web server status and its uptime. Click on the Stop 
HTTP server button in order to stop the web and SOAP servers.

The three areas displayed in the lower part of the window provide information about the web and SOAP 
servers. You define the parameters in the Office Maker Server preferences.

BiblioMaker uses a web server when publishing the online catalogue, but it is not this server. This is why 
it is not necessary (and even not recommended) to start this HTTP server.
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Using Office Maker Server > Real Time Monitor page 

Real Time Monitor page
This page lets you monitor the current operations on the server. It is useful mainly for the Office Maker 
developers and not relevant for the database administrator.
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Using Office Maker Server > Stop Office Maker Server 

Stop Office Maker Server
You stop Office Maker Server by calling the Quit command in the File menu (Windows) or in the applica-
tion menu (macOS). Office Maker suggests to stop after 10 minutes in order to give the users the time to 
disconnect from the server. If no user is connected, Office Maker Server quits immediately.

If users are connected when you ask the server to quit, an alert is displayed on their screen with a countdown. 
If users don’t quit Office Maker on time, they get an error with number -10’002.

If Office Maker Server has been registered as a service (this automates the startup of Office Maker Server 
on the server even if no session is open), you may also stop Office Maker Server using the services control 
panels (under Windows only). But please notice that stopping the Office Maker Server service immediately 
disconnects the currents users without warning.
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Using several Office Maker Server instances
This chapter describes the Office Maker Server setup in 
special cases, such as when several instances of Office 
Maker Server are installed on the same server or in the 
same network.

In the opposite list, click on the topic you are interested in.

Several OM Server software on the same computer	15
Several identical OM Servers on the same network	 19
Several OM Clients on the same computer	 20
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Using several Office Maker Server instances > Several OM Server software on the same computer 

Several OM Server software on the same computer
If you want to use several Office Maker Server applications on the same computer (for instance Office 
Maker Business and Office Maker Finance) or if you want to host several data files of the same program 
on the same server (for instance if you are a trust company managing one Office Maker Finance data file 
for each customer), please read on.
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Using several Office Maker Server instances > Several OM Server software on the same computer 

Several OM Server applications on the same server
If you want to use different Office Maker Server applications on the same computer, install each software as 
described in the installation guide located on the Documentation page on the Office Maker or BiblioMaker 
web site.

Office Maker uses the TCP/IP protocol for communicating between the server and the client computers. 
Each Office Maker server must use a unique TCP port number in order to avoid conflicts.

By default, Office Maker applications are configured in order to use the following TCP port numbers :

Software Client-server SQL* Reserved* Connection** PHP* HTTP* HTTPS*

BiblioMaker 19813 19812 19814 19819 8002 8080*** 8443

OM Business 19813 19812 19814 19819 8002 8080**** 8443

OM Finance 19823 19822 19824 19829 8002 8080 8443

OM Staff 19833 19832 19834 19839 8002 8080 8443

* Not used by default, but reserved by the application. An error message can be displayed by Office Maker Server during 
the startup if this port number is in use.

** Used by the connection dialog of the client application in order to display the server availability (TCP and UDP port).

*** If the WebOPAC module is activated, an additional port (with a customisable number : 80, 8080, etc.) can be used.

**** Used for querying the database from a smartphone.

http://www.officemaker.ch/documentation
http://www.en.bibliomaker.ch/documentation
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Using several Office Maker Server instances > Several OM Server software on the same computer 

If you’d like to use another TCP port number, please proceed as follows:

In each Office Maker Server application, display the Settings>User settings for Data file (under Windows 
in the Edit menu, under macOS in the application menu). Choose the Client-Server>Configuration theme 
and change the port number. After you have saved the preferences, restart Office Maker Server in order 
the changes to be taken in account.

Client computers connect to Office Maker Server with the Office Maker Client application. When connecting 
to the server for the first time, the Client software displays a wizard. If the server address must be entered 
manually, please use the following syntax : [IP address]:[Port number]. Example : 192.168.2.23:19813

If a firewall protects the access to your server, don’t forget to change its settings in order to open the port 
numbers defined on the server. If you don’t open the IP port numbers used by Office Maker Server, the 
client computers will be able to «find» the server, but won’t be able to connect to it (error message with 
number -10’002).
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Using several Office Maker Server instances > Several OM Server software on the same computer 

Several identical OM Server instances on the same server
Each Office Maker Server application is able to open only one data file at a time. If you want to publish 
several data files from the same application on the network (for instance Office Maker Finance), you must 
install one copy of Office Maker Server for each data file; if possible each copy should be in its own folder.

You can simply duplicate the folder containing the first copy of the application.

After you have installed the second copy, open the folder containing the copy of the Office Maker Server 
software :

Windows macOS

Open the folder named Server Database. You 
will find a file sporting the name of the Office 
Maker application, with the extension .4DZ. 
Rename it, leaving its extension (for instance 
OM Finance 2.4DZ).

Display the contents of the Office Maker Server 
package with the contextual menu, then open 
the folder Contents:Server Database. You will 
find a file sporting the name of the Office Maker 
application, with the extension .4DZ. Rename 
the files, leaving its extension (for instance 
OM Finance 2.4DZ).

The name you define here will be used by the Office Maker Client application for the connection to the 
server. This is why we recommend that you give a comprehensible name to these files, so that the users 
may choose the right Office Maker database to connect to.

The port number used by each Office Maker application must be unique. Modify this parameter according 
to the method described above. 

The Office Maker Fi-
nance and Staff Server 
applications can open 
several periods but 
not at the same time 
(switching the period 
is done by calling the 
File>Change period 
command from the 
Office Maker Client 
software). Installing 
several copies of 
Office Maker Server is 
not necessary in this 
case.
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Using several Office Maker Server instances > Several identical OM Servers on the same network 

Several identical OM Servers on the same network
If you install several copies of the same BiblioMaker Server program in the same network (for instance 
several departments in your company using each Office Maker Finance), we recommend that you rename 
the Office Maker Server applications in order to facilitate their identification in the Office Maker Client 
connection dialog box.

The method for renaming an Office Maker Server program is explained above.
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Using several Office Maker Server instances > Several OM Clients on the same computer 

Several OM Clients on the same computer
If several Office Maker Server programs are available on the network and the client computer must be able 
to connect simultaneously to several databases, you can install several copies of the Office Maker Client 
application.

Windows macOS

Please duplicate the folder containing the Office 
Maker Client software located in the Programs 
folder.

Please duplicate the folder containing the Office 
Maker Client Software located in the Applications 
folder.

Using favorites
When starting the Office Maker Client software, press and hold the Shift key until a server connection 
dialog appears.

This dialog consists of two areas: on the left the category area and on the right the list of favorites corres-
ponding to the selected category.

In the left zone, if necessary, create a favorites folder using the + button at the bottom of the zone. You 
add favorites by clicking on the + button in the right zone. Each favorite consists of a freely definable name 
and a server address with the following syntax: [IP address]:[Client-server TCP port number]. Example: 
192.168.1.23:19813 

Once the favorites have been created, simply select the desired favorite and confirm with the Sign in 
button (or double-click on the favorite) to connect to the chosen database.

The colored icons to the left of each favorite provide information on the availability of the databases.
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Office Maker in an heterogenous network
This chapter describes the peculiarities when installing 
Office Maker in an heterogenous network.

In the opposite list, click on the topic you are interested in.

Heterogenous network	 22
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Office Maker in an heterogenous network > Heterogenous network 

Heterogenous network
A network is said heterogenous if the connected computers are based on different platforms : for instance 
macOS and Windows.

Office Maker Server can work in an heterogenous network and communicate simultaneously with client 
computers under macOS and under Windows using the TCP/IP protocol.

Installation and setup of the client computer
Office Maker Server is installed in the usual way. But the preparation of the installation on the client 
computers is particular, because each client computers will use a software developed for its own platform.

The best strategy is to download the Office Maker Client setup program on a file server that can be reached 
by the client computers of each platform. Then, each client computer downloads the setup software from 
the file server and installs Office Maker Client and further files following the above mentioned method.
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Backups
This chapter describes the automatic backups tools 
included with Office Maker.

In the opposite list, click on the topic you are interested in.

Backup strategies	 24
Full Backups	 25
Incremental backups	 27
Restoring a backup	 28
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Backups > Backup strategies 

Backup strategies
Office Maker and BiblioMaker include a backup tool for automating backups.

This backup tool lets you choose between two complementary backup strategies :

•	 Full backup of the data file. This strategy is sufficient if the number of daily changes is not too big.

•	 Incremental backup (all changes brought to the data file, such as adding, modifying and deleting 
records are saved also in a log file). This strategy is useful if the number of daily changes is fairly big.
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Backups > Full Backups 

Full Backups
Start Office Maker Server (under Windows, stop the service first and start up the application with the File 
Explorer).

The main Office Maker Server window shows up and you can see on the Maintenance theme the date 
and time of the next and of the last full backup.

You define the parameters for backups by clicking the Preferences button.

In Backup>Scheduler, define the full backup frequency.

In Backup>Configuration, define the backup contents. Only the data file and the  user structure file need 
to be backed up (the structure file with the .4DC extension correspond to the Office Maker application 
; should you restore the program, we recommend to download it from the Office Maker/BiblioMaker 
website and not from a backup).

Define then the path of the backups with the … button (of course, we recommend to save the backups 
on another physical disk than the disk used for hosting the original data file).

If you’d like to setup the second backup strategy (incremental backup), tick the Use log file check box : 
a dialog box for saving a file is displayed, so that you can choose the log file’s path. We suggest that 
you save the log file in the same folder as the full backups; but prefer a local disk : indeed, the log file is 
continuously open and any network interruption would make it unusable. By default, the log file sports 
the name of the data file followed by the .journal extension (for instance OM Finance.journal).

In Backup>Backup & Restore, define general settings. Normally, only the two first check boxes are 
relevant, as the other settings should be OK for most of the cases.

After you have validated the Preferences, start up manually a full backup with the Backup command in 
the File menu. A dialog box shows up, displaying the date of the last backup and the path of the next 
backup. Validate with the Backup button.
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Backups > Full Backups 

Each backup file sports the name of the original data file followed by the backup number in brackets and 
then finally the .4BK extension (for instance OM Finance[0001].4BK). The backup number is incremented 
by each full backup and lets the administrator quickly find the most recent full backup.
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Backups > Incremental backups 

Incremental backups
The incremental backup saves in a second file all changes brought to the data file (adding, modifying 
and deleting of records) since the last full backup. It lets you restore the last full backup and integrate all 
operations that happened after the full backup, until the crash happened. This file is called the log file.

The incremental backup is synchronised with the full backup. This is why it is necessary to setup and 
perform a full backup before setting up an incremental backup.

Activating the full backups is described in the previous chapter.

A log file is always synchronised with a full backup file, as it contains only the changes brought to the data 
file after the last full backup. By the next full backup, the log file is archived and a new log file is created. 
The current log file always sports the same name. On the other hand, the archives of log files sport the 
name of the log file followed by a number, so that you may identify which full backup a log archive is 
synchronised with (for instance OM Finance[0004].4BL).

Please note that the first archive of a log file sports the number 0000, as the data contained in the first 
log file have been entered before the first full backup.
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Backups > Restoring a backup 

Restoring a backup
When Office Maker Server starts up, the application checks the data file automatically and then detects 
the following possible problems :

1.	 Office Maker Server has unexpectedly quit and the cache memory was empty. In this case, the data 
file on the disk is up to date and does not need to be repaired.

2.	 Office Maker Server has unexpectedly quit and the cache memory contained data that have not been 
saved on disk. In this case, the data file is not up to date and the missing data must be integrated with 
help of the log file.

3.	 Office Maker Server has unexpectedly quit as the application was writing to the data file. In this case, 
the data file is probably damaged : you must restore the last full backup and integrate (with help of 
the log file) the changes brought to the data file after the last full backup.

Restore can be automatic or manual. For security reasons, we recommend to manually restore a database.

Automatic restore needs specific settings in Office Maker Server Preferences. Call the Database 
settings>User settings for Data file in the Edit menu (Windows) or in the File menu (macOS). Choose 
then the Backup>Backup & Restore theme. Two check boxes are displayed :

Restore last backup if database is damaged : this option solves the third above-cited problem.

Integrate last log if database is incomplete : this option solves the second above-cited problem.

Please note that in case of the restore of a full backup, Office Maker Server first renames the damaged 
data file. This file can then be repaired by the server administrator with help of the repairing tool integrated 
in Office Maker Server.
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Backups > Restoring a backup 

Manual restore of a full backup
A full backup may also be restored manually :

With Office Maker Server With Office Maker (single-user version)

In the File menu, choose the Restore… command. Start the single-user of BiblioMaker and press 
the Alt key during the startup, so that you get a 
dialog box giving you several choices. Choose 
the Restore a backup file option.

A dialog box shows up and you may choose the path of the restored data file. By default, the suggested 
path is in the same folder as the backup. If you want to define another location, click on the … button 
and choose the path on the disk. Finally, start up the restore with the Restore button.

The data file is restored in a folder sporting the same name as the data file followed by the backup number 
(for instance OM Finance[0012]. Another folder called Settings is also created.

Move the restored data file to the folder containing the original damaged data file, delete the damaged 
data file and start up Office Maker Server.

Notice : the restored Settings  folder contains a file Backup.4DSettings. This file is a backup of the file 
containing the backup settings. So, if you want to use this settings file again, replace the original file 
located in the Settings folder near the data file.

Please note that it may be easier to setup again the backup settings in the Office Maker Server Database 
settings (Settings>User settings for Data file).
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Backups > Restoring a backup 

Manual restore of an archived log file
You may also restore manually an archived log file :

With Office Maker Server With Office Maker (single-user version)

In the File menu, choose the Restore… command. Start the single-user of BiblioMaker and press 
the Alt key during the startup, so that you get a 
dialog box giving you several choices. Choose 
the Restore a backup file option.

A dialog box shows up and you may choose the path of the restored data file. By default, the suggested 
path is in the same folder as the backup. If you want to define another location, click on the … button 
and choose the path on the disk. Finally, start up the restore with the Restore button.

If you save the restored log archive file in the same folder as the restored full backup (both file names must 
contain the same number), Office Maker Server compares both files and if the restored full backup does 
not contain the last operations saved in the log file, the application asks you if you want to integrate the 
log file into the full backup. If you accept, the integrations starts immediately. Then, the program lets you 
open the restored data file.
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Troubleshooting and documentation
This chapter describes some common issues and their 
solution.

In the opposite list, click on the topic you are interested in.

Troubleshooting	 32
Documentation	 36
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Troubleshooting and documentation > Troubleshooting 

Troubleshooting
The client-server architecture involves three «actors» :

•	 The server

•	 The client computer

•	 The network

When an issue happens, the first thing to do is to discover which one of the «actors» is the origin. Here a 
list of the most common problems :

•	 The program unexpectedly quits or misbehaves when you call a certain function

•	 Error -10’001 or -10’002 displayed on the client computer

•	 When launching the BiblioMaker Client program, you cannot connect to the server
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Troubleshooting and documentation > Troubleshooting 

Symptom : the application unexpectedly quits or misbehaves
When using the application on a client computer, calling a function makes the program misbehave (crash 
for instance). If this behaviour can be repeated each time you call the same command, but only on one 
client computer, the most likely cause is a damaged file on this computer. Indeed, the code of the program 
is executed on the client computer. This code is saved on the hard disk, in a specific folder. You just have 
to quit BiblioMaker Client, delete this folder and to connect again to the BiblioMaker server. The folder 
will be downloaded again from the server.

The path of this folder is the following one :

Windows macOS

C:\Users\[Name of the current account]\
AppData\Local\[Name of the Office Maker 
application]\[Name of the Office Maker appli-
cation followed by the server’s IP address]

Notice : the AppData folder is hidden by default. You may 
make it visible with the following command :

Windows Explorer’s View menu, Options menu, View tab, 
Show hidden files, folder and drives option.

Mac in tosh  HD:Use r s : [ S ta r t  fo lde r ] : 
Library:Caches:[Name of the Office Maker 
application]:[Name of the Office Maker appli-
cation followed by the server’s IP address]

Notice : the Library folder is invisble. You make this folder 
visible by displaying the Start folder in the Finder, then by 
calling the Go>Go to folder… command and by entering 
the Library name.
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Troubleshooting and documentation > Troubleshooting 

Symptom : error -10’001 or -10’002
When using the system on a client computer, an error message is displayed, with error number -10’001 or 
-10’002. These error numbers mean that the client computer cannot communicate with the server.

Regularly (even when the user is not actively using Office Maker), the Office Maker Client sends a message 
to the server to maintain an open connection. Office Maker Server then returns an answer to the client 
computer. If Office Maker Client doesn’t get an answer from the server, after a certain delay it displays 
the error number -10’001 or -10’002.

There are several possible causes to the lack of communication between the client computer and the 
server :

•	 Server crashed : the server’s operating system has crashed and the computer is freezed.

•	 Office Maker Server crashed: Office Maker Server has crashed and has been «ejected» by the operating 
system.

•	 Problem with the network connection : the network is out of order, because there is a software problem 
(router, bridge, network components on the computer and so on) or a hardware failure (network card, 
router, bridge, broken cable, etc.).



35

Troubleshooting and documentation > Troubleshooting 

Check-ups
Here what you can do if the client computer is not able to communicate with the server :

•	 Check if all client computers are concerned with the problem. If it is the case, the problem lies at the 
server or the network level. Otherwise, the client computer should be the cause. Try restarting the 
computer, this solves a majority of such problems.

•	 Start up BiblioMaker Client and try to connect to the server. If this fails, check the server.

•	 If neither the server nor Office Maker Server have crashed, check the server connection with the network 
(«ping» the client computer from the server). If necessary, restart the server.

•	 If Office Maker Server has been stopped in an unusual way (because of a crash for instance), the data 
file could be damaged. In this case, it is highly recommended to verify the data file integrity. This is 
done from the «Maintenance» page in BiblioMaker Server or in the Security and Maintenance center 
in the single-user version of BiblioMaker.

Verifying and repairing an Office Maker / BiblioMakerdata file is described in the Office Maker / BiblioMaker 
handbook, chapter «Maintenance».
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Troubleshooting and documentation > Documentation 

Documentation
Installing and setting up Office Maker Server are described in the installation guide you will find on the 
Office Maker and BiblioMaker web sites.

This installation guide describes a simple configuration, it means only one Office Maker program on the 
server in a homogenous network (i.e. composed only of Macs or of PCs under Windows). If your confi-
guration is different (for instance you would like to install several Office Maker applications on the same 
server and/or use a heterogenous network with a mix of Macs and PCs), please read the chapters Using 
several Office Maker Server instances and Office Maker in an heterogenous network.

Other documents explain how to use Office Maker and BiblioMaker. They can be reached from within the 
client or single-user versions of the software, by calling the Consult documentation/handbook command 
in the Help menu.

http://www.officemaker.ch/en/documentation
http://www.en.bibliomaker.ch/en/documentation


Technical support
In case of an issue, please call our Support 
departement:

0900 576 900 (from within Switzerland)
(Fr. 3.13/minute from the Swiss landline network)

+41 (0)21 651 77 68
(not overtaxed call,

only for users with an update subscription)

Micro Consulting SA
Chemin de Budron A 12

CH-1052 Le Mont sur Lausanne
Switzerland

Web sites :
www.officemaker.ch
www.bibliomaker.ch

http://www.officemaker.ch/documentation
http://www.bibliomaker.ch/documentation
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